Saltar al contenido

HTTP error 505 HTTP Version Not Supported

El servidor no admite, o se niega a admitir, la versión principal de HTTP que se utilizó en el mensaje de solicitud.

El servidor está indicando que no puede o no quiere completar la solicitud utilizando la misma versión principal que el cliente, tal y como se describe en la Sección 2.6 de RFC7230, que no sea con este mensaje de error. El servidor DEBERÍA generar una representación para la respuesta 505 que describa por qué esa versión no es soportada y qué otros protocolos son soportados por ese servidor.

Referencias de programación del Código de Error 505

  • Symfony HTTP Status Constant Response::HTTP_VERSION_NOT_SUPPORTED
  • Python2 HTTP Status Constant httplib.VERSION_NOT_SUPPORTED
  • Python3+ HTTP Status Constant http.client.VERSION_NOT_SUPPORTED
  • Python3.5+ HTTP Status Constant http.HTTPStatus.VERSION_NOT_SUPPORTED
  • Go HTTP Status Constant http.StatusHTTPVersionNotSupported
  • Rails HTTP Status Symbol :http_version_not_supported
  • .NET HTTP Status Constant System.Net.HttpStatusCode.HttpVersionNotSupported
  • C# HTTP Status Enum HttpStatusCode.HttpVersionNotSupported
  • Rust HTTP Status Constant http::StatusCode::HTTP_VERSION_NOT_SUPPORTED

Resumen
Error HTTP 505 HTTP Version Not Supported
Nombre del artículo
Error HTTP 505 HTTP Version Not Supported
Descripción
El servidor no admite, o se niega a admitir, la versión principal de HTTP que se utilizó en el mensaje de solicitud.
Autor
Publisher Name
Códigos HTTP
Publisher Logo